Android app crashes when launching

Mobile Testing, Android App Testing.
g.madlmayr
Posts: 5
Joined: Wed Nov 22, 2017 10:59 am

Android app crashes when launching

Post by g.madlmayr » Tue Jan 18, 2022 3:13 pm

Hi,

I use Ranorex Studio 10.1.5 and wanted to do my first mobile App tests.
I have installed Ranorex Services (Service Version: 2.3.3) on my mobile device (Samsung Galaxy S7, Android Version 8.0.0)
I have established and connected the mobile as endpoint - it is connected.
I have instrumented the application for testing - it is shown in the Ranorex Services App
Ranorex: 10.1.5 AutomationLib: 2.3.3

When I start the app either directly from the Service app or via an existing test (run recording), the app seems to start, but after a view seconds it says "app stopped - restart app". When I restart the app there is another start up, and then the text "app is constantly stopping - close app".

That's all I can achieve - the app does not stay open so I could start recording or run an existing test.

Addition: when I start the "plain" app (the original apk), the app works fine without the ranorex services - so the apk is not the problem.

Any ideas, what I can do to stabilize the app, so I can do some testing?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7465
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Android app crashes when launching

Post by odklizec » Wed Jan 19, 2022 1:07 pm

Hi,

I'm afraid, this kind of issue cannot be solved via forum. I would suggest to contact Ranorex support via support form available here:
https://www.ranorex.com/support-query/
I guess they will need to see the APK and eventually try it on their mobiles?

BTW are you using USB or WIFI connection? Wifi is faster, but USB is more robust. Although I don't think this could be the cause of your problem, try the other connection you are not using now ;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

g.madlmayr
Posts: 5
Joined: Wed Nov 22, 2017 10:59 am

Re: Android app crashes when launching

Post by g.madlmayr » Wed Jan 19, 2022 1:24 pm

Thanks for the reply. Iwill contact support.
I'm using a USB connection, but I guess that's not the problem.

Timo_NN
Posts: 1
Joined: Tue Sep 06, 2022 8:41 am

Re: Android app crashes when launching

Post by Timo_NN » Tue Sep 06, 2022 9:28 am

Hi there, i've got the exact same issue.
Did the Ranorex Support give you a good solution that worked in general, or did you have to change something on your app yourself?

g.madlmayr
Posts: 5
Joined: Wed Nov 22, 2017 10:59 am

Re: Android app crashes when launching

Post by g.madlmayr » Tue Sep 06, 2022 1:19 pm

No - I have raised an issue on support, and asked about 5 times afterwards (within about 2 months), but I only got the message to be a little more patient.
In the meantime we have another (newer) version of the app that works.