Can't Interact with .msi Installer

Technology specific object identification, supported applications, web technologies, and 3rd party controls.
nwilco
Posts: 3
Joined: Mon Nov 29, 2021 2:27 pm

Can't Interact with .msi Installer

Post by nwilco » Mon Nov 29, 2021 2:35 pm

Hi. my AUT is a dotnet application and I want to test the update function, which downloads and runs a .msi installer. But I'm not able to interact with the installer when I'm recording, instead of getting the red dot next to my cursor, it's greyed out. I also can't get anything from it at all with the spy tool. And if I try doing a test step for putting an application in focus, that installer doesn't appear as one of the options to focus on. Can someone let me know where I might be going wrong? Is it even possible? Thanks!

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7469
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Can't Interact with .msi Installer

Post by odklizec » Mon Nov 29, 2021 3:09 pm

Hi,

At first, have you tried to run Ranroex Spy in administrator mode? If not, try it please.

Also, is there an error (instrumentation warning) reported by Spy?

And finally, could you please try to create (and post here) a Ranorex Snapshot (NOT screenshot) of the installation window?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration