Failed to lunch app

Mobile Testing, Android App Testing.
Arez
Posts: 2
Joined: Tue Feb 15, 2022 8:30 pm

Failed to lunch app

Post by Arez » Tue Feb 15, 2022 8:43 pm

Hi,
Our company want to automate iOS native application installed in iPod devices , after installation trial of Ranorex , adding endpoints ipod successfully and the instrumentation was successful done, when I click on record button, I got the app without name in the Choose or add app section and when I select it the error message timeout is showing.

Thank you for help
You do not have the required permissions to view the files attached to this post.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7465
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Failed to lunch app

Post by odklizec » Thu Feb 17, 2022 8:49 am

Hi,

At the moment, there is a known issue with Ranorex instrumentation wizard regarding the iOS apps. So for now it's recommended to instrument the iOS apps via code.

At next, what you can try is to increase Connection and General Timeout values in Ranorex Settings...
MobileSettings.png
You do not have the required permissions to view the files attached to this post.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

Arez
Posts: 2
Joined: Tue Feb 15, 2022 8:30 pm

Re: Failed to lunch app

Post by Arez » Thu Feb 17, 2022 4:44 pm

Hi,
Thank you for feedback,
1- Something I forgot to mention it, just after instrumentation which done successfully, on my device, the iOS app crashes When I select it.
and when I select ios app in Rx ServiceApp, I got the Launch app failure error message (see picture).
2022-02-17_10-35-45.jpg
2- Another question, Now in Choose or add app section, should I have only MiniKeePass icon to select it ?
because actually, I had MiniKeePass and another without name (see picture)
2022-02-17_09-39-54.jpg

3- Even after increase timeout in settings, I had same issue.
I will try to instrument the iOS apps via code then see if resolve the issue.

Thanks
Azedine
You do not have the required permissions to view the files attached to this post.