Instrumented iOS app not able to launch

Ranorex Studio, Spy, Recorder, and Driver.
alessioi
Posts: 4
Joined: Mon Nov 08, 2021 8:13 am

Instrumented iOS app not able to launch

Post by alessioi » Tue Jan 11, 2022 3:56 pm

Hello
I've instrumented a app with the instrumentation wizard but it always fail directly after trying to launch (manually and automatically).

I tried it on iOS 12 & iOS 15.
I was able to identify a problem with the Ranorex signature in the iPhone system logs.

The developer told me that maybe not all libraries where signed during the instrumentation process.

Does anyone know more about this?
In the past it worked but since then several new Ranorex versions and also app versions where released. We have also changed mobileprovisoning and p12 certificate so it's hard to tell where the error is.

Thanks in advance
Alessio
You do not have the required permissions to view the files attached to this post.

Jacob
Certified Professional
Certified Professional
Posts: 120
Joined: Mon Mar 22, 2021 10:01 pm

Re: Instrumented iOS app not able to launch

Post by Jacob » Wed Jan 12, 2022 7:25 pm

Hi Alessioi,

My understanding is that there is currently an incompatibility with the Instrumentation Wizard and iOS 15 using the .p12 and .mobileprovision files for instrumentation. The current workaround is to instrument via source code while the engineering team at Ranorex assess and updates the Instrumentation Wizard for iOS 15.

--Jacob
Image

Bassem.Ibrahim
Posts: 20
Joined: Tue Nov 06, 2018 9:14 pm

Re: Instrumented iOS app not able to launch

Post by Bassem.Ibrahim » Thu Jan 13, 2022 7:29 pm

I was able to instrument(instrumentation wizard) and deploy our latest iOS app on an IPad running iOSv14.3, with Ranorex V9.5.3.
I was having the same crashing problem with iOS15, and now I am able to run my tests.

JuneAmara
Posts: 1
Joined: Fri Feb 04, 2022 9:16 am

Re: Instrumented iOS app not able to launch

Post by JuneAmara » Fri Feb 04, 2022 11:19 am

Has to be compatibility issues

alessioi
Posts: 4
Joined: Mon Nov 08, 2021 8:13 am

Re: Instrumented iOS app not able to launch

Post by alessioi » Wed Mar 09, 2022 7:32 pm

Yes. Ranorex Support told me to use Ranorex 10.1.1 and iOS Versions before 15.
This worked.