iOS app (IPA) has no identifier

Mobile Testing, Android App Testing.
alessioi
Posts: 4
Joined: Mon Nov 08, 2021 8:13 am

iOS app (IPA) has no identifier

Post by alessioi » Wed Mar 09, 2022 7:55 pm

Excuse the big images, I don't know how to make them smaller.

Hi
I've got a iOS application from a costumer to do a POC. I've got a valid Mobileprovision file and a P12.
Instrumentation and deployment works as designed with the wizard. No issues there.

The problem is, that the App seems not to have a bundleID.
I don't know if that's even possible but it just shows a '*' where normally the bundleID is.
I uploaded the app also to a device lab (Sauce Labs) and there was also no bundleID visible.
It is a 2FA app, so it's possible that there are some security restricition.
RanorexServiceApp-iOS.png

When I open the app manually it works fine and I can even see all the Items with RanorexSpy.
But when I want to open the app through Ranorex (automated in Studio or manually from the Service App) I get the following error:
RanorexServiceApp-iOS_LaunchError.png
I can currently only use a iPhone 6 with iOS 12 which is pretty old but the app is still supporting it.
Has someone any Idea on how to resolve this?
The app is developed by a third party so we can not talk to the devs.

Kind regards
You do not have the required permissions to view the files attached to this post.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7465
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: iOS app (IPA) has no identifier

Post by odklizec » Thu Mar 10, 2022 12:54 pm

Hi,

I believe it's a similar (the same) problem, as discussed here:
https://www.ranorex.info/unable-to-laun ... tml#p69980
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration