Jira integration credentials not found

Experiences, small talk, and other automation gossip.
nauman.hameed
Posts: 1
Joined: Tue Sep 06, 2022 3:34 pm

Jira integration credentials not found

Post by nauman.hameed » Tue Sep 06, 2022 3:54 pm

Hi Guys

I have enabled Jira cloud integration in my Ranorex solution. Ranorex version is 10.1.7. I provide my Jira cloud credentials and the integration works when running from Ranorex Studio. However, when I execute from Jenkins via Ranorex runtime, I see this error in attached Ranorex Testscript.

Exception has been thrown by the target of an invocation.<br/>Cannot initialize Jira API because no credentials were found for 'https://enghouseglobal.atlassian.net/'.

Apparently the credentials to Jira cloud are not available when executing through the Ranorex Runtime. Any idea how I can make this work?

Thanks

Nauman Hameed
You do not have the required permissions to view the files attached to this post.

Sudheer Vennamaneni
Posts: 1
Joined: Thu Sep 29, 2022 8:22 am

Re: Jira integration credentials not found

Post by Sudheer Vennamaneni » Fri Sep 30, 2022 12:04 am

Hi Nauman,

Were you able to resolve this issue? I'm getting same error despite providing Jira credentials.

Kind regards
Sudheer

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7465
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Jira integration credentials not found

Post by odklizec » Fri Sep 30, 2022 2:11 pm

Hi guys,

Try the solution described here (remove underscores from jira username):
https://www.ranorex.info/rxagent-but-no ... tml#p68287
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration