Missing the Ranorex Automation AddOn in the Chrome Web Store

Ranorex Studio, Spy, Recorder, and Driver.
User avatar
BMT
Posts: 22
Joined: Fri Jun 12, 2020 11:48 am

Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by BMT » Tue Aug 10, 2021 12:42 pm

Hallo,

since yesterdas we can't find the Ranorex Automation Extension in the Chrome Web Store anymore.
We only find the Ranorex Selocity Extension.

We are dependant on this way of Installation for our Tests.
(we regularly install the Ranorex add-on manually out of the Chrome Web Store - this is the appropriate way for us and our IT architecture)

Could you please give us an info, why the Extension is missing? Is there any reason?
Could you please publish the Ranorex Automation Add-On again?

thank you, Matthias
Image

User avatar
tmcdoniel
Certified Professional
Certified Professional
Posts: 78
Joined: Mon Dec 07, 2020 6:30 pm

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by tmcdoniel » Tue Aug 10, 2021 7:06 pm

The developers are currently working on the issue. So far, it seems that Google changed some policies that blocked the Ranorex extension. Thank you.
Sales Engineer @ Ranorex

mrt
Posts: 257
Joined: Mon Mar 16, 2020 11:31 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by mrt » Wed Aug 11, 2021 8:02 am

same here, addon is uninstalled and can't be installed again, not via chrome web store nor via Ranorex instrumentation wizard.

Please set this as high priority and provide a workaround immediately, currently Ranorex is completely out of order.

thanks, BR mrt

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7470
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by odklizec » Wed Aug 11, 2021 8:16 am

Hi guys,

The only workaround for now, is to enable the Instrumentation property in OpenBrowser action (either in the Properties pane or via code, setting the Instrument parameter to True).
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

mrt
Posts: 257
Joined: Mon Mar 16, 2020 11:31 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by mrt » Wed Aug 11, 2021 8:47 am

Hey odklizec,

the "Instrument" property is (and was already) set to True in my case, but without the Chrome Extension, nothing is recognized inside the browser?

BR mrt

User avatar
BMT
Posts: 22
Joined: Fri Jun 12, 2020 11:48 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by BMT » Wed Aug 11, 2021 9:03 am

Hello,
as far as I know, the Ranorex instrumentation changes the Registry entries for the local machine.

That's not what we want/need - we control the Chrome policies via GPO and in the User Registry.
Means, if the add-on is not on the User forcelist, we manually install the Chrome Extension (and then it's part of the User profile).
Image

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7470
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by odklizec » Wed Aug 11, 2021 9:22 am

mrt wrote:
Wed Aug 11, 2021 8:47 am
Hey odklizec,

the "Instrument" property is (and was already) set to True in my case, but without the Chrome Extension, nothing is recognized inside the browser?

BR mrt
Well, this should definitely work? Are you sure there is no other instance of Chrome or MSEdge running in background? I just tried to open an uninstrumented Chrome with OpenBrowser and instrumentation flag set to True and I works as expected. Ranorex correctly recognizes the elements in existing scenarios and I can even track new elements with Spy. So the OpenBrowser instrumentation works for me.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7470
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by odklizec » Wed Aug 11, 2021 9:25 am

BMT wrote:
Wed Aug 11, 2021 9:03 am
Hello,
as far as I know, the Ranorex instrumentation changes the Registry entries for the local machine.

That's not what we want/need - we control the Chrome policies via GPO and in the User Registry.
Means, if the add-on is not on the User forcelist, we manually install the Chrome Extension (and then it's part of the User profile).
Unfortunately, OpenBrowser instrumentation is currently the only workaround. It seems that the problem is caused by recent changes in Chrome Store? So it's not directly Ranorex-related issue. But Ranorex folks are working on it to resolve the issue ASAP;)
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

mrt
Posts: 257
Joined: Mon Mar 16, 2020 11:31 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by mrt » Wed Aug 11, 2021 11:06 am

odklizec wrote:
Wed Aug 11, 2021 9:22 am
mrt wrote:
Wed Aug 11, 2021 8:47 am
Hey odklizec,

the "Instrument" property is (and was already) set to True in my case, but without the Chrome Extension, nothing is recognized inside the browser?

BR mrt
Well, this should definitely work? Are you sure there is no other instance of Chrome or MSEdge running in background? I just tried to open an uninstrumented Chrome with OpenBrowser and instrumentation flag set to True and I works as expected. Ranorex correctly recognizes the elements in existing scenarios and I can even track new elements with Spy. So the OpenBrowser instrumentation works for me.
Hmm, yes, I have disabled the "keep running in background" in chrome settings, I closed all instances, checked if there are any running chrome processes (there aren't) and ran the test via remote agent again.
It opens the browser with correct URL and then nothing more.

Spy does recognize the chrome window and the menu buttons, but as soon as I hover over any page the instrumentation dialog pops up, installing ofc does not help, and i am not able to recognize any web elements.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7470
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by odklizec » Wed Aug 11, 2021 11:13 am

OK, I'm sorry, but I've tested it locally, not via remote agent. I guess it should work the same, but just for sure, could you please try it on a local machine?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

mrt
Posts: 257
Joined: Mon Mar 16, 2020 11:31 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by mrt » Wed Aug 11, 2021 11:18 am

Alright, I will install studio on the remote agent's machine and try it locally there.

I do not want to sacrifice my local machine for testing purpose, because after I uninstall the Chrome Addon it is gone. ;)

Edit: Ah, it is already there.
Same situation: Opening spy only recognizes the Chrome window itself, but no content inside.

mrt
Posts: 257
Joined: Mon Mar 16, 2020 11:31 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by mrt » Thu Aug 12, 2021 8:58 am

Alright, now I did an upgrade to 10.1.0 and now it also does not work anymore on my local machine.

The browser still shows the Ranorex Addon icon as installed,
the Instrumentation Wizard still reports the Addon as installed,
but neither Spy nor any repository element is able to find anything in the browser.

Any news from Ranorex folks?

bennylew
Certified Professional
Certified Professional
Posts: 24
Joined: Wed Sep 17, 2014 10:43 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by bennylew » Fri Aug 13, 2021 7:49 am

Any updates? We need to install chrome extension...

User avatar
BMT
Posts: 22
Joined: Fri Jun 12, 2020 11:48 am

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by BMT » Fri Aug 13, 2021 8:41 am

Hello,

is there a justified hope that the extension is available soon again?
It really impedes our daily test processes.
Image

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7470
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Missing the Ranorex Automation AddOn in the Chrome Web Store

Post by odklizec » Fri Aug 13, 2021 8:44 am

Hi,

It seems that the extension was mistakenly removed by an automat. New extension is currently under review by Google Chrome team. Hopefully it will be back soon.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration