Not able to recognize objects in SAP 7.7

Experiences, small talk, and other automation gossip.
satauto
Posts: 5
Joined: Mon Oct 18, 2021 7:36 pm

Not able to recognize objects in SAP 7.7

Post by satauto » Tue Oct 19, 2021 5:51 pm

Hi Team,

I am part of automation team and we have a bed of 1000+ testcases which were working in SAP with Internet Explorer browser. But when SAP migrated the browser to Chromium, we are not able to identify objects with Ranorex 10.1.2. Is anyone facing the same issue.?
Please find below the solutions that we have tried on both SAP and Ranorex side:

Solutions Tried from SAP End:
• Enabling Scripting on both Client and Server side
• Uninstalling and re-installing the updated SAP package
• Launched SAP in an Administrator mode

Solutions Tried from Ranorex End:
• Launched Ranorex in an Administrator mode
• Tried enabling/disabling “32/64 bit bridge”
• Tried changing WPF Legacy/UIA Interaction to “WpfOnly” and Show all elements to “True”
• Enabling all the browser extensions(Chromium, Edge & IE)

Here are the versions of software being used:
Automation Tool - Ranorex Ver. 10.1.2
Chromium Browser - Chrome Ver. 94.0.4592.0 (Developer Build) (64bit)
Internet Explorer - IE 10 Ver 20H2, ( OS Build 19042.1288)
.Net Version: v4.6.2 or later
SAP Business Client: 7.70 Final Release PL 3 (64bit)
SAP GUI Version: 770 Final Release PL 2 7700.1.2.1162 (32bit)

Thanks in advance.
Attachments
POS_Screen.rxsnp
(185.07 KiB) Downloaded 19 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7072
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not able to recognize objects in SAP 7.7

Post by odklizec » Thu Oct 21, 2021 7:20 am

Hi,

Thanks for the snapshot. I'm afraid, it says that the BitBridge is disabled, which limits the object recognition. Could you please create another snapshot with enabled BitBridge and SPY started as admin? Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

satauto
Posts: 5
Joined: Mon Oct 18, 2021 7:36 pm

Re: Not able to recognize objects in SAP 7.7

Post by satauto » Thu Oct 21, 2021 5:27 pm

Thank you for the quick response.
As requested, I have launched Ranorex Spy in Admin mode and attached two snapshots, one with BitBridge enabled and one with BitBridge disabled. Please do the needful and do let me know if you need any more information from my end. Thanks in advance.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7072
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not able to recognize objects in SAP 7.7

Post by odklizec » Thu Oct 21, 2021 5:52 pm

Hi,

I’m afraid, you forgot to upload the snapshots?
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

satauto
Posts: 5
Joined: Mon Oct 18, 2021 7:36 pm

Re: Not able to recognize objects in SAP 7.7

Post by satauto » Thu Oct 21, 2021 6:00 pm

I do uploaded the snapshot but while doing that, the system is keep throwing the warning sign(Attached the screenshot for your reference), but still I have submitted the query. If you didn't found the attachment, please let me know what is the better way to upload these snapshots. Thanks
Attachments
Warning_Upload.PNG
Warning_Upload.PNG (16.35 KiB) Viewed 277 times

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7072
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not able to recognize objects in SAP 7.7

Post by odklizec » Thu Oct 21, 2021 6:19 pm

OK, try either zip each snapshot or use One drive, Google drive or similar file sharing service and here post a link. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

satauto
Posts: 5
Joined: Mon Oct 18, 2021 7:36 pm

Re: Not able to recognize objects in SAP 7.7

Post by satauto » Thu Oct 21, 2021 7:27 pm

Hi,

As requested, I have uploaded the snapshot into Google Drive. Please let me know if you can't able to access it. Thanks.

https://drive.google.com/drive/folders/ ... sp=sharing

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7072
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Not able to recognize objects in SAP 7.7

Post by odklizec » Fri Oct 22, 2021 7:21 am

Hi,

Thanks for the snapshots. Now I see the WinForms recognition error.

I'm afraid, I have no solution for you, aside the obvious "Please check the WinForms troubleshooting guide available here..." https://www.ranorex.com/help/latest/int ... eshooting/

However, I forwarded your problem to Ranorex team for review.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

satauto
Posts: 5
Joined: Mon Oct 18, 2021 7:36 pm

Re: Not able to recognize objects in SAP 7.7

Post by satauto » Tue Oct 26, 2021 7:49 pm

Thank you. Appreciate your help on this.