Progress form doesn't display after upgrade to 9.3.2

Ask general questions here.
colin
Posts: 3
Joined: Mon Oct 12, 2020 2:04 pm

Progress form doesn't display after upgrade to 9.3.2

Post by colin » Mon Oct 12, 2020 3:12 pm

I upgraded from 5.2.4 to 9.3.2, using Visual Studio to create the solution.
The Progress Form no longer displays when running a test.
Is this a bug or have I missed something in the upgrade process?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6795
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Progress form doesn't display after upgrade to 9.3.2

Post by odklizec » Wed Oct 14, 2020 6:26 am

Hi,

Have you checked if the progress form is enabled in test suite settings and if not, re-enable it?...
show-progress-dialog-window-not-visible ... tml#p33228
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

colin
Posts: 3
Joined: Mon Oct 12, 2020 2:04 pm

Re: Progress form doesn't display after upgrade to 9.3.2

Post by colin » Wed Oct 14, 2020 11:40 am

Thanks for your reply.
I am using Visual Studio rather than Ranorex Studio. Can I get to these settings another way?

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 6795
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Progress form doesn't display after upgrade to 9.3.2

Post by odklizec » Wed Oct 14, 2020 11:50 am

Hi,

It should be possible via code described here:
test-argument-to-hide-the-progress-bar- ... tml#p47463
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration

colin
Posts: 3
Joined: Mon Oct 12, 2020 2:04 pm

Re: Progress form doesn't display after upgrade to 9.3.2

Post by colin » Wed Oct 14, 2020 3:01 pm

Hi
Ranorex.Controls.ProgressForm.Show() is in the code as it was before the upgrade, but isn't having any effect now.

Isaac
Posts: 2
Joined: Sun Feb 02, 2020 5:11 am
Location: South Africa
Contact:

Re: Progress form doesn't display after upgrade to 9.3.2

Post by Isaac » Fri Apr 02, 2021 5:45 am

Hi I'm having same issue also. Since I upgraded from 9.4.1 and now 9.5. Mine it first shows and in the middle of execution disappears and sometimes can even run show to end. I did request the support team to help, since they said they are investigating the matter. I've enabled the Progress form code from Ranorex code entry file Program.cs, with this two code lines "Ranorex.Controls.ProgressForm.Show(); Ranorex.Core.Configuration.Current.SaveToUserSettings(); ", from Test suite properties and Test suite General settings but still no luck. I also went extra mile by creating and attaching user code cs file"ShowprogressD" with the two lines mentioned in Program.cs file on Test suite or every Test case Setup. All this never worked. My server OS Name: Windows server 2012. I've attached the two cs files
Attachments
Program.cs
Ranorex main cs Entry file
(1.66 KiB) Downloaded 14 times
ShowProgressD.cs
cs User code file attached to Test suite setup or every test case setup
(1.39 KiB) Downloaded 14 times