Page 1 of 1

QT Application

Posted: Wed Jun 21, 2017 11:06 am
by hanguyen2009
Hi Supporter,
We used Ranorex running auto compare pdf file via diffpdf application that build on QT framework 4.8.5.
At about 2 months ago it worked well, but now some of user's computers does not work because Ranorex does not identify object in the diffpdf application.
We compare environment with computer doing work and not work, has differences only about of Microsoft Office. In the computer work has Office 2010, and other has Office 2016. I don't know this is cause of issue, isn't it.

We saw the technology limitation stated "Please make sure that your QT application uses the QT accessibility plugin and that your QT version has been compiled with accessibility support." and we check on all our computer, the QT SDK isn't installed on these, so we can't copy accessibility directory follow as guidance.

We attached file snapshot it worked and diffpdf application.
please change name files
diffpdf-2.1.3-win32-static.001.7z -> diffpdf-2.1.3-win32-static.7z.001
diffpdf-2.1.3-win32-static.002.7z -> diffpdf-2.1.3-win32-static.7z.002
and upzip these files

Please help,


Re: QT Application

Posted: Fri Jun 23, 2017 8:32 am
by RobinHood42
Hi hanguyen2009,

I've tested your application and it works on my machine.


Win10 64bit
Rx 7.0.1

Please ensure that Rx is started with the same privileges as the application under test. Furthermore, you could try to enable the QT legacy mode:
Robin 8)