Warning Symbol in Ranorex Spy also AUTOMATIONID

Ranorex Studio, Spy, Recorder, and Driver.
QATest879
Posts: 27
Joined: Fri Jul 02, 2021 2:35 pm

Warning Symbol in Ranorex Spy also AUTOMATIONID

Post by QATest879 » Thu Dec 02, 2021 9:55 pm

I'm testing a java application and when I launch it normally from my OS, Ranorex Spy can find it and there's no issues, and I started using Host.Local.RunApplication to launch it and it was still fine. But I made some other changes and now for some reason when I launch the program using my Ranorex project and run Spy on it, there's a yellow exclamation box next to the application in the repository as if there's a warning for some reason. And all of the repository items say "AutomationID" in their RanoreXPath names also now... Does anybody know what it means or how to stop it from happening since Ranorex can't find the repository items it needs due to this issue.

User avatar
odklizec
Ranorex Guru
Ranorex Guru
Posts: 7426
Joined: Mon Aug 13, 2012 9:54 am
Location: Zilina, Slovakia

Re: Warning Symbol in Ranorex Spy also AUTOMATIONID

Post by odklizec » Fri Dec 03, 2021 8:43 am

Hi,

Could you please post a Ranorex snapshot (NOT screenshot), taken at a time when it shows the exclamation mark? My guess is, that the application was not instrumented correctly? Snapshot could tell us more. Thanks.
Pavel Kudrys
Ranorex explorer at Descartes Systems

Please add these details to your questions:
  • Ranorex Snapshot. Learn how to create one >here<
  • Ranorex xPath of problematic element(s)
  • Ranorex version
  • OS version
  • HW configuration